
Curriculum Vitae
Dries Verachtert > java software engineer

 & linux administrator



Personal details

Nationality > Belgian

Languages > Dutch (mother tongue), French, English, German (notions), Japanese (notions)

Date of birth > February 28, 1978

e-Mail > dverachtert@ithomi.com

Mobile > +32 (0)473 / 81 24 13

Education

Licentiaat Informatics

1996-2001 > KU Leuven

Additional relevant education

J2EE, J2ME & related technologies and XP (eXtreme Programming)

… - present > Self-study by means of books, online articles and exams at http://www.javablackbelt.com/

Specific knowledge 

REQUIREMENTS CAPTURE

Activities > Use-Case modelling, Software requirements specifications, Functional Design

Tools > Rational Rose, Together J, MS Visio

OO ANALYSIS & DESIGN

Languages > UML

Skills > Design patterns, frameworks like Jakarta Struts

Tools > Rational Rose, Together J, Word

IMPLEMENTATION

Languages >
Java, Perl, PHP, Python, C, C++, Pascal
XML, XSLT, (D)HTML, JavaScript, bash scripting
SQL

Technologies >
J2EE (SOAP, Enterprise JavaBeans, JSP, Servlets, JavaBeans, JMS, JDBC, …), Jakarta 
software (Struts, Lucene, Log4j, Commons, Cocoon), LDAP, GWT, Spring
ASP

Development  Tools >
Eclipse, Borland JBuilder, Together J
XML Spy, Macromedia Dreamweaver
TOAD (Oracle Tool), Oracle Enterprise Manager
Xdoclet (generation of J2EE classes)

Runtime Environments >
OS: Linux (advanced), Solaris, Windows 3.x > XP, DOS, Portex
J2EE: JBoss, Tomcat, Enhydra, Resin, older versions of IBM WebSphere & iPlanet
Databases: PostgreSQL, Oracle, MySQL, MS SQL Server, MS Access

TESTING

Tools > JMeter, JUnit, PMD, Hudson
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DEPLOYMENT

Tools > Jakarta Ant, InstallShield (for Win32 applications)

CONFIGURATION & CHANGE MANAGEMENT

Tools > CVS, Subversion, Rational ClearCase, PVCS, Visual SourceSafe

SOFTWARE DEVELOPMENT PROCESS

Methodologies > 
Rational Unified Process
eXtreme Programming

SYSTEM ADMINISTRATION

Operating systems >
Excellent knowledge of Linux
Solaris
FreeBSD
Windows 2000, XP and MacOS X

Web servers > 
Apache, PHP, glassfish, Tomcat, JBoss, Squid, mod_jk, mod_perl, warp, JRun, Resin, 
Enhydra

Mail servers > 
Postfix, sendmail, Qmail

Name servers >
bind

File sharing > 
NFS, samba

Networking > 
Firewalls, forwarding, masquerading, VPNs (PPTP), socks5, snort

Misc daemons > 
Openssh, ftp (wu-ftpd, proftpd), ntpd, squid, CVS
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Experience > ithomi nv

SEPTEMBER 2004 – CURRENT > DEVELOPER & SYSTEM ADMINISTRATOR

Project > Agence Europe – Dantemail2

General > 
Agence Europe is an international press agency specialised in news about the European Union.     A 
central server needs to accepts newsletters written in Word from the journalists. Certain information 
has to be extracted and converted to other formats (for example xml). Also personalised PDF 
documents have to be generated and mailed to the list of subscribers.

Involved in > Analysis and design, end to end development of functionalities

Involved knowledge > Java, OpenOffice java bindings, GWT (Google Web Toolkit), JUnit,  Maven2, Spring

Environment > Jakarta Tomcat 5.5

Tools > Eclipse, Subversion, Hudson

Duration > October 2008-February 2009

Project > Belmedim – RIA Project

General > 
Belmedim provides services and solutions geared at the global group of diagnostic radiology 
professionals. The primary product of Belmedim is a knowledge database for the field. Several 
extensions had to be made for the product such as a rich content editor, article versioning and an 
author registration procedure.

Involved in > Analysis and design, end to end development of functionalities

Involved knowledge > Java, iBatis, Dojo, JUnit, JavaScript, Struts2, Maven2

Environment > Jakarta Tomcat 5.5

Tools > Eclipse, CVS, Maven, Continuum

Duration > July 2008-September 2008

Project > Agfa Gevaert / Agfa Healthcare – Drystar medical printers

General > 
Design, implementation and maintenance of software at the Healthcare/Hardcopy/Dry imagers 
departement at Agfa:

• Design, implementation and maintenance of java software running on medical printers (CR/DR 
and Mammo). The Java software runs on an embedded real time operating system called 
Portex on the PowerPC platform. I was involved in bug fixing, adding new functionality and in 
the maintenance of the codebase. The code  has been in active development since 1998 and 
consist of +/- 1 million lines of mainly java code.

• Design, implementation and/or maintenance of various java and C# applications running on 
Windows XP for automatic testing of printers, for emulating a printer on a pc and for testing 
the translations of the local and remote user interface of the printers (24 languages).

• Design, implementation and maintenance of unit tests for testing the structure and the 
dependencies within the user interface which was partly encoded in xml.

Involved in > Almost all of the software made for the Drystar printers

Involved knowledge > Java, Embedded programming, HTML

Environment > Portex, Windows XP

Tools > Eclipse, Rational ClearCase, Rational ClearQuest, Rational Rose, Ant, Cruisecontrol

Reference > http://www.agfa.com/en/he/solutions/radiology/digital_hardcopy/dry_imagers/index.jsp

Duration > March 2005-June 2008

Project > Agence Europe – DanteWeb

General > Development of a web application which allows clients of Agence Europe to read & search online a 
per-client  configurable  list  of  daily  multilingual  bulletins  and  whereby  only  a  limited  number  of 
simultaneous sessions are allowed for a client’s IP-address or IP-range.  

Involved in > Automation of the distribution of the pdf files. 

Involved knowledge > J2EE (JSP, taglibs, Servlets, JDBC), Perl

Environment > IBM WebSphere + Tomcat, MS Access, Windows NT server
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Tools > IntelliJ Idea, MS Access, Ant, Macromedia Dreamweaver

Reference > http://www.agenceeurope.com/

Duration > Small changes occasionally

Project > Rpmforge – Creation of +/- 1300 rpm package specifications of open source projects

General > Rpmforge is a collaboration of packagers of open source software. In total we have packages of +/- 
2700 open source programs whereof +/- 1300 packages are made by me.  These packages are used by 
system administrators  and Linux users  worldwide and we currently  have more  then 7 mirrors  for 
distributing the load of the site. The sites receive hits from more then 100 countries.

Involved in > 

• Creation and maintenance of spec files and rpm files.
• Design and implementation of a build system.
• Bug hunting and fixing of software which we package.

Involved knowledge > 
Thorough knowledge of packaging on RPM based Linux distributions.
Good knowledge of a lot of languages for debugging open source programs ( C, C++, Java, Perl, 
Python, Autoconf & automake scripts, bash scripts and windowing toolkits like KDE, Gnome, Qt, Gtk, 
WxWindows)

Environment > Red  Hat Linux 6 till  9,  Aurora  Linux 1.0,  1.91 and 1.92 (sparc,  discontinued),  Red Hat 
Enterprise Linux 3, 4 and 5, CentOS 3, 4 and 5, Fedora Core 1 to 10.

Tools > Python, Perl, bash scripting, subversion

Reference > http://dries.eu/ and http://dries.ulyssis.org/rpm/

Duration > As hobby since November 2003

Project > Belmedim – site as proof of concept 

General > After some discussions about the requirements of the site, a proof of concept has been made. The 
site permits easy searching for diseases and has the possibility to do an export to xml or pdf of all the 
information in the database. 

Involved in >
• Design & implementation
• Bug hunting & fixing
• Staging deployment

Involved knowledge > Linux, Apache, CVS, Java, PostgreSQL, XML, XSLT, XSL-FO, FOP

Environment > Java, Linux

Duration > May 2004

Project > DAV – sites for the ‘Dienst voor de Administratieve Vereenvoudiging’ 

General > Design and implementation of an advanced CMS built on open source software for managing the 
sites http://www.kafka.be and  http://www.vereenvoudiging.be for the federal government department 
‘Dienst voor de Administratieve Vereenvouding’ (DAV). The CMS has been extended with modules for 
newsletters, for a quiz and for handling large amounts of user input.

Involved in >
• Design & implementation
• Bug hunting & fixing
• Deployment

Involved knowledge > Linux, Apache, PHP, PostgreSQL, XML, XSLT

Environment > PHP

Duration > September 2004 – February 2005
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Experience > Edesign sa/nv

MAY 2003 – SEPTEMBER 2004 > DEVELOPER & SYSTEM ADMINISTRATOR

Project > Edesign – eDocPort 

General > Edesign (http://www.edesign.be) creates products for maintaining electronic forms and documents. 
The primary  product  is  eDocPort.  My work  consisted  of:  the  integration  with  Tamino XML Server, 
integration with Jway forms, automatic tests with Apache JMeter, standardisation of the installation with 
Ant, development and design of a lot of new features and bugfixing.

Involved in >
• Design & implementation
• Bug hunting & fixing
• Staging & production deployment
• J2EE connectivity (SOAP, EJB)
• Design and implementation of the database handlers for PostgreSQL and Tamino XML

Involved knowledge > 
Linux, Apache, CVS, Java, PostgreSQL, Oracle 9i, Tamino XML Server, Apache Jmeter, SOAP, EJB

Environment > Java, Linux

Project > Edesign – System administration

General > Administration of the Linux servers at Edesign: configuration and maintenance of HTTP servers, 
database servers, CVS servers, DNS servers and the firewall.

Involved knowledge > Linux, iptables, snort, Oracle 9i, PostgreSQL, MySQL, Apache, Tomcat, bind, Resin, 
shell scripting (bash), perl, CVS

Experience > I-Merge nv

JULI 2001 – MAY 2003 > DEVELOPER

Project > UnderTheCork NV – UnderTheCork site 

General  >  For  UnderTheCork  (http://www.underthecork.com),  I-Merge  did  the  analysis,  design, 
implementation and deployment of a full scale e-commerce site for selling wine. New modules such as 
stock management have been added after the launch of the website.

Involved in >
• Design & implementation
• Production deployment

Involved knowledge > Apache, Linux, PHP, Oracle 8i, HTML, JavaScript

Environment > Apache + Oracle 8i, Linux

Tools > Oracle Enterprise manager

Project > Poppunt VZW - Poppunt site

General >  The Poppunt site (http://www.poppunt.be) consists of an online database of musicians, groups, 
concerts, bargains etc.

Involved in >
Design & implementation
Production deployment

Involved knowledge > Apache, JRun, Enhydra, Resin, Tomcat, JSP, XSLT, JavaMail, JDBC, PostgreSQL, CVS, 
MySQL, Linux, perl

Environment > Apache + Resin, PostgreSQL, Linux

Tools > CVS
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Project > Belgian Post Group - PostBox / Certipost Web application

General > The PostBox (http://www.postbox.be) is a project of the Belgian Post Group (BPG). Every Belgian 
can get a free, secured and identified PostBox account. Currently, the customer can use this account to 
send and receive mails and fill-in e-forms. In the future, the customer will be able to send registered 
mails (CertiPost).

Involved in >
• Design & implementation of certain parts
• Testing & bug hunting
• Staging & production deployment

Involved knowledge > Solaris, Apache, Tomcat, iPlanet, JSP, Servlets, XSLT, JMS, log4j, Struts, JDBC, PVCS 
Tracker, CVS, HighDeal (payment system), Syntegra (LDAP and  mail), Oracle 9i, Shell programming 
(bash & tcsh), perl.

Environment > Apache + Tomcat, Oracle, Solaris

Tools > CVS, PVCS Tracker

Project > The Flemish government – kleurrijk Vlaanderen site

General > The site consists of a CMS and a lot of forums for moderated discussions. 

Involved in >
Design & implementation of certain parts (forums)
Testing

Involved knowledge > IIS, ASP, MS SQL Server

Environment > IIS, Windows 2000 Server

Project > The Flemish government – 10 ministeriële sites

General >  The ’10 ministeriële sites’  consists  of  a CMS with separate  subsites  for every minister  of  the 
Flemish government. Every department is able to change the pages of it’s own subsite.

Involved in >
Design & implementation
Testing & bug hunting

Involved knowledge > IIS, ASP, MS SQL Server

Environment > IIS, Windows 2000 Server

Project > I-Merge – System administration

General > Administration of the Linux servers at I-Merge: configuration and maintenance of HTTP servers, 
database servers, CVS servers, DNS servers, squid servers and firewalls.

Involved knowledge > Linux, ipchains, iptables, snort,  Oracle 8i, PostgreSQL, MySQL, Apache, Tomcat, 
PPTP, vtund, bind, Resin, shell scripting (bash), perl, CVS

Project > Miscellaneous small websites

General > 
Mostly bug hunting and fixing, replacing persons who are sick or on vacation, helping coworkers to 
reach a deadline.
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Experience > Personal projects

Project > LevenInLeuven.be

General  >  Founder  of  leveninleuven.be,  a  site  written  for  and  written  by  people  living  in  Leuven.  I'm 
responsible for the hosting and maintenance of the site and i also write and edit a large part of the 
articles.

Involved in >
Maintenance of the site
Writing articles

Involved knowledge > PHP, Apache, PostgreSQL, MySQL, Wordpress

Environment > Linux

Reference > http://leveninleuven.be/

Project > Rpmrepo.org

General > There are multiple groups of packagers working on rpm packages for enterprise distributions like 
CentOS. The goal is to collaborate and to merge into one project so there's less duplication of work. 
Currently people from rpmforge.net, atrpms.net, CentOS and Scientific Linux are involved.

Involved in >
Meetings and discussions

Involved knowledge > rpm packaging

Environment > Linux

Reference > https://rpmrepo.org

Project > Fotosite

General > Fotosite is an easy tool for managing a large repository of photos (+/- 20000 photos currently). The 
administrator must be able to easily add, modify and search individual photos and groups of photos. 

Involved in >
Design & implementation

Involved knowledge > PHP, JBOSS, Java J2EE EJB, PostgreSQL, MySQL

Environment > Linux

Project > Cocoon support

General > Apache Cocoon is a web development framework based on ‘component pipelines’  where each 
component is specialized for a particular operation. I’ve given a lot of support during the development 
of two sites fully based on Cocoon.  Because a lot of the functionality of Cocoon was used and because 
the documentation of Cocoon is far from perfect, we learned a lot of the internals of Cocoon by reading 
the source. 

Involved in >
Research & Development

Involved knowledge > Tomcat, Cocoon

Environment > Linux
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Experience > during studies

ULYSSIS > 
ULYSSIS (Unix Lovers Yield Student Services & Internet Support, http://www.ulyssis.org) is a student 
organisation which maintains some HTTP, DNS, shell, IRC, CVS, socks5, FTP, email and database 
servers for students and organisations at the K.U.Leuven. ULYSSIS also does the following

• Organise activities like html competitions, lectures and lanparties.
• Cooperate in the organisation of large activities like the 24Urenloop.
• Help people with computer problems by mail, news, IRC and webpages.

I've been chairman of this organisation during two years. I've been responsible for the contacts with for 
example sponsors and also for maintaining a lot of the machines.

KotNet > 
KotNet is the network of the K.U.Leuven students (ca. 10000 computers). Together with other students, 
I was responsible for the DNS and mail administration of the kotnet.org domain.

I-Merge > 
I worked during the holidays (August 2000) for I-Merge. My work consisted of configuring oracle 8i 
databases, apache webservers and firewall and also programming backsites in PHP 4 and Perl. 

Umicore > 
My work during the holidays consisted of extending an access database with additional forms and also 
with visual basic code to automatically fill-in Excel sheets. 
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